App Member logout without warning

  • Premium Member

    It's not a big problem, but sometime I'm logout by the app. That in itself isn't really a problem, it's not exclusif to that app and I just need to login again. The real problem is that there is no warning about not being login anymore, and when you try to acces a member only chapter rather explaining that you need to be a member to acces that chapter the app keep showing the loading screen forever. When you know of the issu you quickly login, but the first time i thought that the app was broken for 3 days. Just adding a message when you doesn't have a member account log in would resolve the problem.

  • Premium Member

    It usually happens when the server-side session tokens are invalidated (by a reboot, or code change, or something went wrong, etc). The next version of the app is going to automatically redirect you to the login screen if you try to access something without a valid session token.

  • Premium Member

    Since I work in a near Farraday Cage, I have it happen quite often due to app disconnecting to server for too long.

  • Premium Member

    Your login session isn't based on an ongoing connection, so that shouldn't really be an issue... And partial offline support (by caching the last few parts) should help alleviate the burden of spotty connections to some degree. I'm not sure if the partial offline support is planned for this next version, or the one after that, but I do remember Jaon (the app developer) talking about it.

  • @jampodevral
    The app fetches your user data at the startup. The process will fail if your token is invalid or the server is inaccessible. In former case you would want to forget the token and ask user to log in. The old (current non-beta) version invalidates token even in case of unreachable network, effectively logging you out.
    The beta version won't log you out in that case, though from some reports it seems like it won't log you out even if it does reach the server and get "unauthorized" response.

    @guspaz said in App Member logout without warning:

    tokens are invalidated (by a reboot

    They what? that's not how databases work.

  • Premium Member

    @_08 IIRC they're not kept in persistent storage, but in memcached or equivalent? I don't really remember anymore, I just know that reboots have been one of the causes for session tokens being wiped out before.

  • Member

    Yeah, this is really annoying. The other day i spent a LOT of time trying to figure out why i couldn't read any books in the app. I'd tap on a new chapter, and it would show me a loading screen...


    I thought something was up with my internet, and tried various things, before realizing the app logged me out for no reason, without warning. And it just let me TRY to read a story, without actually telling me i couldn't, as if to waste my time.

    Really irritating.

  • Premium Member

    I just experienced the same issue on the beta. It just kept saying it was loading with no error message to let me know why it wasn't working.

  • Premium Member

    I have this happen quite frequently. Several times it'll happen in the middle of reading; I'll exit the app and when I come back, after discovering that I've been logged out (after waiting for a chapter to load for ten minutes....) I'll find that my previous reading progress wasn't saved and I have to figure out where I am :(

  • Yeah same, but since my iPad remembers the password plus email it only takes one click to sign back in. Weirdly enough it doesn’t sign me out the forums. So I can still see what’s up with the JNC community.

  • Premium Member

    @hyferzftw Sam added an update on Testflight yesterday that supposedly fixes the glitch. Probably fixed it on Google Play as well.